C70 Nuevo propietario C70 (sensor velocidad de crucero)

quinoshark

Miembro Novato
8 Oct 2009
28
10
2021
#1
Hola, recientemente he adquirido un bonito Volvo C70, todavía no me lo han entregado por que tiene un error en el sensor del pedal de la velocidad de crucero, lo tiene ya el mecánico dos semanas y no parece que de la la solución, han probado con un sensor nuevo y nada, y claro ya no se que hacer, por que el coche es precioso y lo he negociado bastante y no voy a encontrar ninguno así y menos por ese importe. Se os acurre alguna posible solución ??, muchas gracias
C70 modelo 2007, 2.4 Gasolina
 
Última edición:
14 Ene 2021
341
354
Madrid
#2
Hola, para poderte ayudar, sería bueno si puedes ampliar de que año/versión es en C70, y que tipo de código de error en concreto tiene.
 
#4
Un error en el sensor de posición del pedal acelerador te debería dar más problemas, no solo con el control de velocidad de crucero. ¿Qué código de error da?

¿En marcha, acelera, decelera y mantiene bien la velocidad o tiene fluctuaciones?

¿En marcha el velocímetro te marca bien la velocidad?

Tras cambiar el sensor ¿ha sido borrado el error?

Enhorabuena por la adquisición, yo tengo uno, es el segundo c70 que tengo y me tiene enamorado aunque seguramente lo venda pronto.
 
JAD

V4L

Miembro Master
18 Abr 2017
4.551
1.743
Madrid
#6
No hay ningún sensor de velocidad crucero, lo que existe son sensores de posición del embrague y el interruptor de freno. Que empiecen por ahí, revisando las alimentaciones y señales que llegan a las centralitas
 
'Me Gusta': alfe

quinoshark

Miembro Novato
8 Oct 2009
28
10
2021
#7
Hola, recientemente he adquirido un bonito Volvo C70, todavía no me lo han entregado por que tiene un error en el sensor del pedal de la velocidad de crucero, lo tiene ya el mecánico dos semanas y no parece que de la la solución, han probado con un sensor nuevo y nada, y claro ya no se que hacer, por que el coche es precioso y lo he negociado bastante y no voy a encontrar ninguno así y menos por ese importe. Se os acurre alguna posible solución ??, muchas gracias
C70 modelo 2007, 2.4 Gasolina
Lo cierto es que el coche va todo super bien, hasta me lleve a mi sobrino que controla bastante de mecánica y le metió su maquina de diagnosis y no salía nada, lo probamos en carretera y nos fijamos de que el el sensor se activaba per no fijaba la velocidad, pero no salía ningún aviso, total que le dije al propietario que lo arreglase para poder comprárselo, y le ha puesro un sensor nuevo y ahora sale el error y ya voy para 3 semanas.
 
'Me Gusta': alfe

quinoshark

Miembro Novato
8 Oct 2009
28
10
2021
#8
Un error en el sensor de posición del pedal acelerador te debería dar más problemas, no solo con el control de velocidad de crucero. ¿Qué código de error da?

¿En marcha, acelera, decelera y mantiene bien la velocidad o tiene fluctuaciones?

¿En marcha el velocímetro te marca bien la velocidad?

Tras cambiar el sensor ¿ha sido borrado el error?

Enhorabuena por la adquisición, yo tengo uno, es el segundo c70 que tengo y me tiene enamorado aunque seguramente lo venda pronto.
Pues yo era un satisfecho propietario de un V50, pero tuve un accidente y no lo puede reparar, y ahora quería este modelo que me vuelve loco.
 
18 Abr 2017
4.551
1.743
Madrid
#9
Lo cierto es que el coche va todo super bien, hasta me lleve a mi sobrino que controla bastante de mecánica y le metió su maquina de diagnosis y no salía nada, lo probamos en carretera y nos fijamos de que el el sensor se activaba per no fijaba la velocidad, pero no salía ningún aviso, total que le dije al propietario que lo arreglase para poder comprárselo, y le ha puesro un sensor nuevo y ahora sale el error y ya voy para 3 semanas.
revisa los sensores de los pedales ¿te aparece la palabra "cruise" en la pantalla?
 

Burgoscom

Miembro Elite
6 Jun 2015
4.719
2.157
#13
por dar ideas, a parte del sensor de velocidad, verificar que está correcto el interruptor del pedal de freno, dando por sentado que el fusible del sistema del control de crucero está bien.
 
'Me Gusta': alfe
14 Ene 2021
341
354
Madrid
#14
por dar ideas, a parte del sensor de velocidad, verificar que está correcto el interruptor del pedal de freno, dando por sentado que el fusible del sistema del control de crucero está bien.
Si el error que os da es en el sensor del pedal de embrague, tal como recomienda @Pablo MP , debéis o bien reemplazar ese sensor o enfocar la diagnosis hacia ese punto, que luego puede que haya más mal, pero solucionar ese primero. Lo fatal que puede pasar en un sistema de control de velocidad es que no se desactive ante cualquier señal por pequeña que sea de cualquier sensor, de freno, embrague, botón de off, por eso el firmware/software evalúa en tiempo real todas las señales inhabilitantes y desconecta en 0, todo el sistema ante la más mínima evidencia de señal. Por seguridad.
 
Última edición:
#15
Si el error que os da es en el sensor del pedal de embrague, tan como recomienda @Pablo MP , debéis o bien reemplazar ese sensor o enfocar la diagnosis hacia ese punto, que luego puede que haya más mal, pero solucionar ese primero. Lo fatal que puede pasar en un sistema de control de velocidad es que no se desactive ante cualquier señal por pequeña que sea de cualquier sensor, de freno, embrague, botón de off, por eso el firmware/software evalúa en tiempo real todas las señales inhabilitantes y desconecta en 0, todo el sistema ante la más mínima evidencia de señal. Por seguridad.
Puede que acabes de dar en la diana...
 
'Me Gusta': alfe
18 Abr 2017
4.551
1.743
Madrid
#16
@quinoshark te dejo esto por aquí (había etiquetado a otro compañero)

esto es para el 4 cilindros, tanto diesel como gasolina
4cyl.PNG
Este es para el 5 cilindros, ambos combustibles también:
5cyl.PNG


Los elementos que pueden fallar:
  1. 7/51: Pedal de acelerador (no debería fallar, pues funciona sin el cruise)
  2. 7/123: Sensor del pedal de embrague, situado en la parte del vano motor, acoplado al cilindro maestro del embrague.
  3. 7/124: Sensor del pedal de freno, situado en el servofreno.
  4. 3/39: interruptor de pedal de embrague (si es 4 cilindros), situado en el interior del habitáculo, en el bastidor del pedal del embrague

Como salta el error en el pedal del embrague toca revisar el cableado desde el elemento 7/123 si es 5 cilindros o el 3/39 si es 4 cilindros hacia la CEM y corroborar que no haya cables sueltos, seccionados o incluso una CEM corroida.

Con todo esto y paciencia se debería poder llegar a la solución.

De todos los modos, recuerdo, que al menos en mi coche para activar y setear una velocidad, primero debes pulsar la palabra cruise y después actuar en el botón + o - para fijar la velocidad, sino no se queda fijada.
 
Última edición:
'Me Gusta': alfe

quinoshark

Miembro Novato
8 Oct 2009
28
10
2021
#17
Si el error que os da es en el sensor del pedal de embrague, tal como recomienda @Pablo MP , debéis o bien reemplazar ese sensor o enfocar la diagnosis hacia ese punto, que luego puede que haya más mal, pero solucionar ese primero. Lo fatal que puede pasar en un sistema de control de velocidad es que no se desactive ante cualquier señal por pequeña que sea de cualquier sensor, de freno, embrague, botón de off, por eso el firmware/software evalúa en tiempo real todas las señales inhabilitantes y desconecta en 0, todo el sistema ante la más mínima evidencia de señal. Por seguridad.
Ok , muchas gracias
 
'Me Gusta': alfe

quinoshark

Miembro Novato
8 Oct 2009
28
10
2021
#20
El taller es oficial Volvo o no?
Hola, pues tengo el coche con el problema, es que no se enciende el sensor, bueno se enciende cuando quiere pero no se activa, no se que hacer si llevarlo a la Volvo de aquí en Murcia, por que mi mecánico de confianza, tampoco sabe bien como solucionarlo, y no conozco a ningún mecánico o taller que sepa de estos problemas.
 
'Me Gusta': alfe