Página 3 de 5 PrimerPrimer 12345 ÚltimoÚltimo
Resultados 21 al 30 de 42

Se me ha ido el puerto de OBD del coche a la KK!

...

  1. #21
    Miembro Master
    País
    Spain
    Avatar de CrazyHorse

    Fecha de ingreso
    26 mar, 10
    Ubicación
    Schwyz, Suiza y Los Angeles, USA (PingPong)
    Mensajes
    3,372
    Entradas de blog
    6
    Modelo
    S80 T6

    Predeterminado Re: Se me ha ido el puerto de OBD del coche a la KK!

    Cita Iniciado por RAMALOJI Ver mensaje
    supongo que intentas leer el volvo con el motor en marcha no?

    puedes conectar con otro protocolo ?
    Si, tanto con la llave en posición II, como con el motor encendido.

    Mañana pruebo con otro protocolo...


    Mil gracias!

  2. # ADS
    Circuit advertisement
    Fecha de ingreso
    Always
    Ubicación
    Advertising world
    Mensajes
    Many
     

  3. #22
    Miembro Master
    País
    Spain
    Avatar de RAMALOJI

    Fecha de ingreso
    20 abr, 07
    Mensajes
    4,205

    Predeterminado Re: Se me ha ido el puerto de OBD del coche a la KK!

    no se que puede pasar pero .lo mejor siempre es que el conector tenga el chip ELM 327 no uno basado en el

    a ver si detecta CAM y te prioriza el modo

    es algo raro ,cuando conectas en el volvo se alimenta el adaptador

    lo detectas por BT

    se empareja DE NUEVO BIEN

    mantiene el port COM

  4. #23
    Miembro Master
    País
    Spain
    Avatar de RAMALOJI

    Fecha de ingreso
    20 abr, 07
    Mensajes
    4,205

    Predeterminado Re: Se me ha ido el puerto de OBD del coche a la KK!

    a lo mejor no conecta bien con el motor en parado

    a mi se me desconecta cuando paro el motor

  5. #24
    Miembro Master
    País
    Spain
    Avatar de CrazyHorse

    Fecha de ingreso
    26 mar, 10
    Ubicación
    Schwyz, Suiza y Los Angeles, USA (PingPong)
    Mensajes
    3,372
    Entradas de blog
    6
    Modelo
    S80 T6

    Predeterminado Re: Se me ha ido el puerto de OBD del coche a la KK!

    Actualizo el status, que en lineas generales sigo igual. (Perdón por el tocho, pero ya es que ni duermo, bueno sí, duermo encima de google...)

    Procedimiento usado.
    1) Garantizar la estabilidad del "Dongle", alias conector OBDII. Las pruebas realizadas incluyen el testeo con otro coche de su operación con al menos un programa. Esto se ha conseguido, pudiendo enlazar y leer parámetros con él. Así pues, el dongle tiene actividad (tiene tensión) y envía/recibe datos desde el PC y envía/recibe datos desde un coche, tanto desde el fiat como desde el volvo. La diferencia estriba en lo que pasa a continuación.

    2) Esto descarta problema de comunicaciones a nivel informático. Los puertos COM del pc están perfectamente mapeados, ya que de no ser así no tendría capacidad de lectura nunca (con ningún programa).

    Es más, en el volvo el conector OBDII y el PC se enlazan perfectamente y tratan de transferir información. El dongle, con una seguridad del 95%, está funcionando. No es un 100% porque no todos los fabricantes ni todos los modelos de un fabricante se comportan igual, ya que los pines del conector que usan no son EXACTAMENTE los mismos. Lo que en un fiat puede funcionar, en un volvo puede que no. El 5% de margen de error se cancela o bien probando con otro "dongle" contra mi S80 o bien con otro S80 y mi Dongle, a ser posible anterior al 2002. Esto todavía no lo he conseguido porque no he tenido acceso ni a una cosa ni a otra. El dongle tiene el chip ELM327, no una emulación/adaptación/sucedáneo. Lo desmonté y lo vi.

    aquí el reverso del PCB del dongle y su pineado
    DSC00037..JPG
    DSC00036..JPG

    Aquí los pines que usa la hembra del coche.
    DSC00022..JPG

    3) Tratar de encontrar una traza con algún programa del error que "levanta" al tratar de conectar. Ramaloji, de momento he de desechar el PCMScan porque, como he instalado versiones "de dudosa procedencia", no me lee nada, ni con un coche ni con otro. Así pues, he de eliminar problemas. Me faltaría "hacer limpieza en el SO" (o montar otro) y reinstalarlo. He probado con otro programa, el que venía con el dongle (VitalScan), y lee el fiat todos los parámetros que puede leer, pero en el volvo no se llega a conectar. También he probado con el OBDSpy, que curiosamente es el que me está poniendo en la pista del problema real.

    4) El OBDSpy, únicamente cuando conecto con el volvo, me levanta un error que dice "Can't initialize OBD connection".

    Navegando por la red, llego a dos documentos que me hacen replantearme la situación del problema:
    Este es el primer Link: http://www.obdclearinghouse.com/OBD-...arr-Issues.pdf
    Este es el segundo link: http://www.google.es/url?sa=t&source...lEI8oHQdaGJv1w

    Según el primer link (página 7), una ECU que cumpla con el standard KWP2000 (ISO 14230-4), espera una inicialización de la comunicación utilizando un protocolo determinado. Si la comunicación se inicializa usando otro protocolo puede la cosa no funcionar.

    Se da la situación que los fabricantes de "herramientas" no creen que sea necesario implementar el método de inicialización rápida Y lenta, sólo uno de ellos. Y se da la situación que muchos coches rechazan la inicialización en distinto modo de la que la esperan (como puede ser el caso).

    Según el segundo link (página 5), la ECU del S80 T6 del año 1999 cumple con los stándares ISO9141-2/ISO14230-4, así pues me inclino a pensar que NI SIQUIERA ES UN PROBLEMA DE HARDWARE (pines/conectores/programas/etc), sino de SOFTWARE del propio coche (o de los protocolos de inicialización que soporta el dongle: aaaamigo, aquí está la diferencia entre uno de "los chinos" y uno de verdad....)

    Y ahora viene la de traca: ¿cómo apaño esto? Me da miedo imaginarme las posibles soluciones....

  6. #25
    Miembro Master
    País
    Spain
    Avatar de RAMALOJI

    Fecha de ingreso
    20 abr, 07
    Mensajes
    4,205

    Predeterminado Re: Se me ha ido el puerto de OBD del coche a la KK!

    los problemas se conocen cuando se prueba

    no se si tu adaptador puede conectar por CAM.

    deberas de probar con otro adaptador o con otros programas

    prueba el VOL FCR

    si estubieras cerca podriamos probar con otros adaptdores

    y con programas registrados con todo tipo de protocolos

    te toca currar un poco en pos de los s 80

  7. #26
    Miembro Master
    País
    Spain
    Avatar de RAMALOJI

    Fecha de ingreso
    20 abr, 07
    Mensajes
    4,205

    Predeterminado Re: Se me ha ido el puerto de OBD del coche a la KK!

    Los Tres Sabores del OBD II
    Si bien los parámetros, o las lecturas , requeridos por reglamentaciones OBD II son uniformes, los fabricantes de automóviles había una cierta libertad en el protocolo de comunicaciones que utiliza para transmitir las lecturas de los escáneres . Naturalmente , cada uno sentía que tenía la única manera verdadera , así que tenemos tres diferentes comunicaciones DAB II protocolos en uso.

    ¿Qué Protocolo de Comunicaciones utiliza mi vehículo?
    Como regla general , los coches y camiones de GM luz SAE J1850 VPW uso ( variable Pulso de Amplitud Modulada ) . productos de Chrysler y todos los europeos y asiáticos utilizan la mayoría de las importaciones ISO 9141 circuitos. Ford utiliza SAE J1850 PWM ( modulación por ancho de pulso ) patrones de comunicación.
    Hay algunas variaciones en las importaciones en cautividad , como el Cadillac Catera , un alemán Opel derivados , que utiliza la norma ISO 9141 Europeo protocolo.

    En 1996 y más tarde los vehículos , puede decirle qué protocolo se utiliza al examinar el conector OBD II :

    J1850 VPW - El conector debe tener contactos metálicos en los pines 2 , 4 , 5, y 16, pero no 10.
    ISO 9141-2 - El conector debe tener contactos metálicos en los pines 4 , 5, 7, 15 y 16.
    J1850 PWM - El conector debe tener contactos metálicos en los pines 2 , 4, 5, 10 y 16.





    -

  8. #27
    Miembro Master
    País
    Spain
    Avatar de RAMALOJI

    Fecha de ingreso
    20 abr, 07
    Mensajes
    4,205

    Predeterminado Re: Se me ha ido el puerto de OBD del coche a la KK!

    al principio usaba el elm de cable

    y ahora estoy usando en BT por eliminar cables este:

    http://cgi.ebay.com/ebaymotors/WIREL...tomotive_Tools

    y afirma compatibilidad con todos estos

    http://www.diydiagnostics.com/vehicles_tested.htm


  9. #28
    Miembro Master
    País
    Spain
    Avatar de RAMALOJI

    Fecha de ingreso
    20 abr, 07
    Mensajes
    4,205

    Predeterminado Re: Se me ha ido el puerto de OBD del coche a la KK!

    aqui puedes ver el dat sheet del elm 327

    http://www.elmelectronics.com/DSheets/ELM327DS.pdf


    como veras los el pinado es diferente para cada protocolo

    mira la pagina 64 del PDF



    o no todos los adptadores estan montados conformes

    a las recomendaciones de elmelectronics

    y no todos los elm 327 son originales

    .

  10. #29
    Miembro Master
    País
    Spain
    Avatar de CrazyHorse

    Fecha de ingreso
    26 mar, 10
    Ubicación
    Schwyz, Suiza y Los Angeles, USA (PingPong)
    Mensajes
    3,372
    Entradas de blog
    6
    Modelo
    S80 T6

    Predeterminado Re: Se me ha ido el puerto de OBD del coche a la KK!

    Ese va a ser el siguiente paso, Ramaloji. Cambiar el Dongle (punto 2). Mi adaptador, de hecho, se conecta por CAN. Veré el que me comentas, pero me parece un poco "caro"...

    Lo que me escama es que sigo pudiendo usarlo con el fiat perfectamente. Y lo que me escama más aún: cómo es posible que hace una semana me funcionase en el mismo Volvo? La verdad, aunque cambie de adaptador, quisiera entender quién ha escrito qué en dónde para impedir la conexión. Según en qué casos puede ser interesante...

  11. #30
    Miembro Master
    País
    Spain
    Avatar de RAMALOJI

    Fecha de ingreso
    20 abr, 07
    Mensajes
    4,205

    Predeterminado Re: Se me ha ido el puerto de OBD del coche a la KK!

    a ver en algunas ECUs puedes conectar por dos protocolos distintos

    para visualizar dos tipos se datos y aunque cumplan ciertos requisitos

    basicos pueden existir diferiencias notables y ademas existe cierto secretismo

    para evitar que se escapen los clientes

    asi que se trata del juego delgato y el raton


    muchos adptadores de BT no tienen buffer para manejar la cantidad de datos

    o velocidad suficiente para conectar a ciertas velocidades

    pero a lo mejor es algo mas simple ,

Página 3 de 5 PrimerPrimer 12345 ÚltimoÚltimo

Temas similares

  1. Donde encuentro el puerto OBD II en un S40 de 2002 ?
    Por fjdpn2 en el foro VOLVO S40/V40/V50
    Respuestas: 3
    Último mensaje: 14/03/2012, 12:04
  2. saludos desde Puerto Rico
    Por Oscar Medina en el foro Presentacion
    Respuestas: 2
    Último mensaje: 28/09/2011, 08:43
  3. Puerto OBDII en 850 ´96
    Por Hasala en el foro VOLVO 200/300/400/700/800/900/S90/V90
    Respuestas: 9
    Último mensaje: 27/05/2011, 00:01
  4. Instalar puerto USB
    Por ISRA_C30T5 en el foro Audio y multimedia Volvo
    Respuestas: 3
    Último mensaje: 29/06/2010, 14:09
  5. PUERTO CAN-BUS PARA TODOS LOS COCHES.
    Por NEOFAIRFORCE. en el foro Area Tecnica Volvo
    Respuestas: 46
    Último mensaje: 20/04/2009, 06:35

Marcadores

Marcadores

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •